RDS MySQL会不定期地更新代理小版本,本文介绍RDS MySQL数据库代理的内核小版本更新记录以及查看代理内核小版本的方法,帮助您快速了解各小版本的新功能、优化改进及Bug修复等信息。
关于RDS数据库代理的使用问题和更多相关信息,欢迎加入用户钉钉群(106730000316)进行咨询、反馈和交流 。
说明 如何升级数据库代理的小版本,请参见升级数据库代理内核小版本。 关于RDS MySQL内核的小版本说明,请参见AliSQL内核小版本发布记录。 查看当前版本:在实例的数据库代理页面的基本信息 > 代理小版本处查看。 在 代理小版本 右侧可单击 升级 进行版本升级。 查看可升级版本:单击代理小版本处的升级,查看可升级到版本。 说明 下表仅包含数据库代理的主流版本,并不包含所有数据库代理版本。您查询到的版本号,可能并不包含在下列的版本列表中。 小版本 说明 2.25.14 Bug 修复 修复HTAP场景下explain select语句在只有一个AP节点时路由错误的问题。 修复开启事务级连接池且发生被动HA切换时,schema复用可能会出错的问题。 2.25.12 Bug 修复 修复HTAP场景下AP节点复制中断时,失败的SQL未重新路由回TP节点的问题。 2.25.11 新功能 适配MySQL 8.4。 Bug 修复 修复HTAP场景不兼容性SQL没有重新路由到TP节点执行的问题。 修复单条会话上只读事务执行后,负载偶发不均的问题。 修复高可用架构下主库瞬时延迟高,导致连接断开的问题。 2.25.9 新功能 优化了一致性读在低并发场景的性能。 Bug 修复 修复一处由于HTAP引入的连接保持非预期的闪断。 2.25.8 新功能 支持 HTAP行列自动分流。 Bug 修复 修复重放失败读请求到主节点可能 crash 的问题。 2.25.7 Bug修复 修复一致性读在写并发大时,一致性可能失效的问题。 2.25.5 新功能 支持事务回放功能,对于正在进行中的事务,也能在切换时连接保持。 Bug修复 修复MySQL主节点crash后原地快速拉起时,新建连接可能阻塞的问题。 修复变更代理参数或节点时,可能会导致部分长连接负载不均的问题。 2.25.4 新功能 支持选择基于活跃请求数的负载均衡路由策略,详见负载均衡算法。 支持配置主节点作为只读代理的兜底节点。 2.25.3 Bug修复 修复事务级连接池建立连接偶发性报错的问题。 2.25.2 新功能 MySQL 5.6支持一致性读特性。 Bug修复 修复列名为 修复因wait_timeout导致会话非预期断开的问题。 2.25.1 新功能 读写分离支持设置读一致性级别。 2.24.3 Bug修复 修复列名为disable关键字导致SELECT FOR UPDATE语句报错的问题。 修复因wait_timeout导致会话非预期断开的问题。 修复添加只读节点时,事务级连接池导致Schema错误的问题。 2.24.1 Bug修复 修复后端连接recv-q过大导致的OOM问题。 修复添加节点时事务级连接池schema复用不正确的问题。 2.9.5 新功能 支持设置最小保留实例数。 Bug修复 修复高网络延迟下单连接带宽受限的问题。 修复故障节点恢复后负载可能不均的问题。 2.9.3 Bug修复 修复读写分离模式在某些长连接场景下可能出现负载不均衡的问题。 修复2.9.1版本引入的SHOW WHERE语句导致的内存泄漏问题。 2.9.1 新功能 支持读写属性为只读的连接地址设置连接池和延迟阈值。 支持被动切换场景的连接保持。 连接保持优化,支持保持RC隔离级别下没有写入的事务。 Bug修复 修复线程ID轮转导致的 修复在只读地址上执行 2.8.41 新功能 升级内核版本至社区2.3.15版本。 说明 确保当前RDS MySQL实例内核小版本在20240131及其以上。如需升级,请参见升级内核小版本。 1.14.8/1.14.9 Bug修复 修复Kill语句可能导致会话卡死的问题。 修复权重为0的只读节点无法成功Kill会话的问题。 修复高网络延迟下单连接带宽受限的问题。 修复故障节点恢复后负载可能不均的问题。 修复MHD线程卡死导致任务流失败的问题。 修复系统在处理短连接场景时出现的内存泄漏问题。 修复force_node语法不生效的问题。 1.14.7 新功能 增加连接保持失败次数的性能监控。 Bug修复 修复MySQL 5.7升级至8.0过程中JDBC报错的问题。 修复MySQL 5.6实例锁定可能导致集群建立连接认证不通过的问题。 修复MySQL 5.7中Crash快速拉起导致的Proxy协议失效问题。 修复库表恢复过程中,请求可能报错的问题。 1.14.6 新功能 新增主动切换场景下的连接保持功能。 1.14.5 Bug修复 兼容MySQL 8.0.33的Session tracker,修复开启连接池功能后可能导致客户端连接断开的问题。 1.14.3/1.14.4 Bug修复 修复代理防双写功能对主节点判断异常,导致代理地址不可用的问题。新增代理防双写功能错误码,触发代理防双写功能时,客户端会收到对应的报错。 修复账号host为CIDR格式时,代理地址认证不通过的问题。 修复事务拆分未开启时,事务内第一条读转发到只读节点的问题。 1.14.1/1.14.2 新功能 新增代理防双写功能,避免异常切换场景下出现双主,导致数据写入错乱。开启防双写功能后,如果出现多个主节点,代理地址无法连接。 1.13.42 Bug修复 修复数据库连接过多导致建立连接失败的问题。 修复内部定时任务导致响应时间(RT)抖动的问题。 1.13.41 性能优化 优化在大量错误认证场景下数据库代理的性能。 优化账号认证功能。当存在错误账号认证时,限流由全局粒度限流修改为账号粒度限流。 Bug修复 修复事务拆分时导致的事务状态丢失的问题。 修复事务级连接池中环境变量没有重新设置的问题。 修复分布式事务(XA事务)下Prepare Statement关闭失败的问题。 修复若干内部异常问题。 1.13.33 新功能 支持MySQL utf8mb3编码格式。 Bug修复 修复Prepare Statement参数过多导致SELECT FOR UPDATE路由不正确的问题。 1.13.27 性能优化 优化了INSERT语句代理Parse的性能。 Bug修复 修复了某些客户端SSL兼容性的问题。 1.13.25 Bug修复 修复认证失败导致的代理内存泄露问题。 修复多Endpoint场景下可能导致代理异常Crash的问题。 1.13.22 新功能 支持INSERT操作后通过 支持FOUND_ROWS函数。 支持将COM_STATISTICS路由至只读实例。 优化事务级连接池。 支持将GEO函数路由至只读实例。 增加部分内部监控指标。 Bug修复 连接不会再被发送至RDS中锁定的实例。 修复因部分语句解析不正确导致路由错误的问题。 修复某些场景下stmt_exec失败的问题。 修复 1.13.17 Bug修复 修复部分内部错误。 1.13.5 新功能 支持路由所有请求至指定节点(Force Node Connection)。例如: 说明 若指定的节点存在异常,则会返回 支持路由某一条请求至指定节点(Force Node Query)。例如: 说明 若指定的节点存在异常,则会返回 增加部分内部监控指标。 Bug修复 修复语句中包含MODE关键字导致请求被路由到只读实例的问题。 修复某些条件下负载不均衡的问题。 1.12.10 新功能 支持独享代理连接地址的SSL加密。 Bug修复 修复MySQL 8.0的SSL建立连接异常问题。 修复当节点从异常状态变成正常后,独享代理将新请求路由到该节点异常的问题。 1.12.7 新功能 支持 支持XA事务语法。 Bug修复 修复MySQL 8.0的 修复若干事务级连接池的问题。 修复若干建立连接失败的问题。 1.11.12 新功能 支持事务级连接池。 Bug修复 优化长连接的负载均衡,当节点从异常状态变成正常后,旧的长连接新请求可以再次路由到该节点。 优化Prepare语法,支持Prepare单播。 修复当MySQL 5.7连接MySQL 5.6数据库,开启Deprecate EOF导致连接失败的问题。 修复存储过程中更改数据库时导致连接断开的问题。 修复当结果集里大报文单行超过16 MB数据时,客户端报 修复只读实例通过 修复 修复 修复同个用户多个host的认证失败问题。 1.10.7 Bug修复 修复会话级连接池的若干问题。 1.9.23 新功能 支持root账号连接。 支持SSL连接。 Bug修复 修复 修复 修复客户端收到sequence错误报文,导致应用报 修复主实例异常时只读实例的连接被断开问题。 1.9.14 新功能 支持hint语法: Bug修复 修复charset默认值获取错误导致的乱码问题。 修复返回MySQL版本号的String不正确问题。 API 描述 查询数据库代理详情。查看代理内核小版本
小版本更新说明
disable关键字导致SELECT for UPDATE语句报错的问题。thread id already exists错误问题,使线程ID尽量不轮转。Kill Query操作时由于没有进行广播,此请求可能不会被Kill的问题。SELECT LAST_INSERT_ID()语句来获取分表的唯一ID。load data infile语句执行失败的问题。/*force_proxy_internal*/set force_node = 'pi-123';表示该连接后面的所有请求只路由至指定的pi-123节点上执行。set force node 'pi-123' is not found, please check.错误。/*force_node='pi-123'*/ show processlist;表示该请求只路由至指定的pi-123节点上执行。'force hint server node is not found, please check'.错误。show full processlist语法。show processlist报错问题。Packets out of order错误的问题。set autocommit=0打开的事务未及时关闭问题。lock in shared mode语句被路由到只读实例的问题。select handler from abc for update语句被路由到只读实例的问题。change user失败问题。load file失败问题。Exception: Packets out of order错误的问题。/*FORCE_SLAVE*/, /*FORCE_MASTE*/。相关文档
相关API