腾讯云云数据库MySQL迁移到阿里云RDS MySQL

2026-06-29   访问量:1029


本文介绍腾讯云云数据库MySQL迁移到阿里云云数据库RDS MySQL实例的注意事项及操作步骤。

前提条件

源端及目标端

要求

相关参考

源端

腾讯云云数据库MySQL实例

  • 已开通公网访问,并获取外网连接地址及端口。

  • 已创建高权限账号。

腾讯云云数据库MySQL官网文档

目标端

阿里云云数据库RDS MySQL实例

  • 已创建阿里云RDS MySQL实例。

  • 已创建高权限账号。

迁移限制

  • 结构迁移不支持event的迁移。

  • 对于MySQL的浮点型float和double,DTS通过round(column,precision)来读取该列的值,若列类型没有明确定义其精度,对于float类型,精度为38位,对于double类型,精度为308,请先确认DTS的迁移精度是否符合业务预期。

  • 如果使用了对象名映射功能后,依赖这个对象的其他对象可能迁移失败。

  • 当选择增量迁移时,源端的MySQL实例需要按照要求开启binlog。

  • 当选择增量迁移时,源库的binlog_format要为row。

  • 当选择增量迁移且源MySQL如果为5.6及以上版本时,它的binlog_row_image必须为full。

  • 当选择增量迁移时,增量迁移过程中如果源MySQL实例出现因实例跨机迁移或跨机重建等导致的binlog文件ID乱序,可能导致增量迁移数据丢失。

说明          

腾讯云云数据库MySQL参数的修改,请参见腾讯云云数据库MySQL官网文档。

注意事项

对于七天之内的异常任务,DTS会尝试自动恢复,可能会导致迁移任务的源端数据库数据覆盖目标实例数据库中写入的业务数据,迁移任务结束后务必将DTS访问目标实例账号的写权限用revoke命令回收。

操作步骤

  1. 进入目标地域的迁移任务列表页面(二选一)。

    通过DTS控制台进入

    通过DMS控制台进入

    说明

    实际操作可能会因DMS的模式和布局不同,而有所差异。更多信息。请参见极简模式控制台和自定义DMS界面布局与样式。

    1. 登录DMS数据管理服务。

    2. 在顶部菜单栏中,选择Data + AI > 数据传输(DTS) > 数据迁移。

    3. 在迁移任务右侧,选择迁移实例所属地域。

    4. 登录数据传输服务DTS控制台。

    5. 在左侧导航栏,单击数据迁移。

    6. 在页面左上角,选择迁移实例所属地域。

    1. 单击创建任务,进入任务配置页面。

    2. 可选:在页面右上角,单击试用新版配置页。

      说明

      • 若您已进入新版配置页(页面右上角的按钮为返回旧版配置页),则无需执行此操作。

      • 新版配置页和旧版配置页部分参数有差异,建议使用新版配置页。

    3. 配置源库及目标库信息。

      警告                

      选择源和目标实例后,建议您仔细阅读页面上方显示的使用限制,否则可能会导致任务失败或数据不一致。

      类别

      配置

      说明

      无

      任务名称

      DTS会自动生成一个任务名称,建议配置具有业务意义的名称(无唯一性要求),便于后续识别。

      源库信息

      选择已有连接信息


      数据库类型

      选择MySQL。

      接入方式

      选择公网IP。

      说明                        

      实例地区

      选择腾讯云MySQL数据库所属地域。

      说明                        

      若选项中没有腾讯云MySQL数据库所属的地域,您可以选择一个该数据库距离最近的地域。

      域名或IP地址

      填入腾讯云MySQL数据库的外网地址的域名部分。

      端口

      填入腾讯云MySQL数据库的外网地址的端口部分。

      数据库账号

      填入腾讯云MySQL的腾讯云数据库的默认高权限账号:root。

      数据库密码

      填入该数据库账号对应的密码。

      连接方式

      请根据实际情况选择非加密连接或SSL安全连接。

      目标库信息

      选择已有连接信息


      数据库类型

      选择MySQL。

      接入方式

      选择云实例。

      实例地区

      选择目标RDS MySQL实例所属地域。

      是否跨阿里云账号

      本示例使用当前阿里云账号下的数据库实例,需选择不跨账号。

      RDS实例ID

      选择目标RDS MySQL实例ID。

      数据库账号

      填入目标RDS MySQL实例的数据库账号,需具备读写权限。

      数据库密码

      填入该数据库账号对应的密码。

      连接方式

      根据数据库实际情况选择非加密连接或SSL安全连接。如果设置为SSL安全连接,您需要提前开启RDS MySQL实例的SSL加密功能,详情请参见使用云端证书快速开启SSL链路加密。

      • 若您需要使用已录入系统(新建或保存)的数据库实例,请在下拉列表中选择所需的数据库实例,下方的数据库信息将自动进行配置。

        说明

        DMS控制台的配置项为选择DMS数据库实例。

      • 若您未将数据库实例录入到系统,或无需使用已录入系统的数据库实例,则需要手动配置下方的数据库信息。

      • 若腾讯云MySQL未开启SSL加密,请选择非加密连接。

      • 若腾讯云MySQL已开启SSL加密,请选择SSL安全连接。同时,您还需要上传CA 证书并填写CA 密钥。

      • 可以单击右侧获取DTS IP段查看、复制对应地区的IP段。

      • 如果您的实例进行了访问限制,请先放开对应地区公网IP段的访问权限后,再配置数据迁移任务。

      • 若您需要使用已录入系统(新建或保存)的数据库实例,请在下拉列表中选择所需的数据库实例,下方的数据库信息将自动进行配置。

        说明

        DMS控制台的配置项为选择DMS数据库实例。

      • 若您未将数据库实例录入到系统,或无需使用已录入系统的数据库实例,则需要手动配置下方的数据库信息。

    4. 配置完成后,单击页面下方的测试连接以进行下一步。

    5. 如果您的自建数据库具备白名单安全设置,您需要复制弹跳框中的DTS服务器IP地址,并加入自建数据库的白名单安全设置中。然后单击测试连接。

      警告

      DTS自动添加或您手动添加DTS服务的公网IP地址段可能会存在安全风险,一旦使用本产品代表您已理解和确认其中可能存在的安全风险,并且需要您做好基本的安全防护,包括但不限于加强账号密码强度防范、限制各网段开放的端口号、内部各API使用鉴权方式通信、定期检查并限制不需要的网段,或者通过内网(专线/VPN网关/智能网关)的方式接入。

    6. 配置任务对象。

      • DTS任务暂不支持使用pt-online-schema-change等类似工具执行Online DDL变更,否则会导致DTS任务失败。

      • 各阶段处理方式如下:由于库表结构迁移与全量迁移阶段不允许执行库或表结构变更的DDL操作,因此不受Online DDL策略控制。

      • 是:会迁移Online DDL操作产生的临时表(例如_表名_gho)的数据变更。

      • 否,适配DMS Online DDL与否,适配gh-ost:根据正则表达式规则过滤掉gh-ost等工具产生的临时表(例如_表名_gho)的数据变更。

      • 库表结构迁移:不受Online DDL策略控制,会创建相关临时表。

      • 全量迁移:不受Online DDL策略控制,全量迁移对象中将不包括临时表的迁移,凡是表名满足正则表达式(^_(.+)_(?:gho|new)$或^_(.+)_(?:ghc|del|old)$)的表都会被过滤。

      • 增量迁移:受Online DDL策略控制。

      • 是:迁移Online DDL变更产生的临时表数据。

        说明

        Online DDL变更产生的临时表数据过大,可能会导致迁移任务延迟。

      • 否,适配DMS Online DDL:不迁移Online DDL变更产生的临时表数据,只迁移源库使用数据管理DMS(Data Management)执行的原始DDL语句。

        说明

        该方案会导致目标库锁表。

      • 否,适配gh-ost:不迁移Online DDL变更产生的临时表数据,支持自定义过滤规则。DTS将根据正则表达式规则过滤掉gh-ost等工具产生的临时表(例如_表名_gho)的数据变更。您可以根据需要,修改用于匹配影子表和无用表的默认正则表达式:

        说明

        该方案会导致目标库锁表。

      • 影子表:^_(.+)_(?:gho|new)$

      • 无用表:^_(.+)_(?:ghc|del|old)$

      • 针对同源或者同目标的多个DTS实例,网络重试时间以后创建任务的设置为准。

      • 由于连接重试期间,DTS将收取任务运行费用,建议您根据业务需要自定义重试时间,或者在源和目标库实例释放后尽快释放DTS实例。

      • 是:不在源库中写入心跳SQL信息,DTS实例可能会显示有延迟。

      • 否:在源库中写入心跳SQL信息,可能会影响源库的物理备份和克隆等功能。

      • 是:配置ETL功能,您还需要在文本框中输入数据处理语句。

      • 否:不配置ETL功能。

      • 不设置:不设置告警。

      • 设置:设置告警。您还需要设置告警阈值和告警联系人,当迁移失败或延迟超过阈值后,系统将进行告警通知。

      • 如果只需要进行全量迁移,建议同时选中库表结构迁移和全量迁移。

      • 如果需要进行不停机迁移,建议同时选中库表结构迁移、全量迁移和增量迁移。

      • 若未选中库表结构迁移,请确保目标库中存在接收数据的数据库和表,并根据实际情况,在已选择对象框中使用库表列名映射功能。

      • 若未选中增量迁移,为保障数据一致性,数据迁移期间请勿在源实例中写入新的数据。

      • 仅当迁移类型选择了库表结构迁移时才可以配置。

      • 若选择是,则可能会增加预检查时间。您可以在预检查阶段查看评估结果,评估结果不影响预检查结果。

      • 预检查并报错拦截:检查目标数据库中是否有同名的表。如果目标数据库中没有同名的表,则通过该检查项目;如果目标数据库中有同名的表,则在预检查阶段提示错误,数据迁移任务不会被启动。

        说明

        如果目标库中同名的表不方便删除或重命名,您可以更改该表在目标库中的名称,请参见库表列名映射。

      • 忽略报错并继续执行:跳过目标数据库中是否有同名表的检查项。

        警告

        选择为忽略报错并继续执行,可能导致数据不一致,给业务带来风险,例如:

      • 全量期间,DTS会保留目标集群中的该条记录,即源库中的该条记录不会迁移至目标数据库中。

      • 增量期间,DTS不会保留目标集群中的该条记录,即源库中的该条记录会覆盖至目标数据库中。

      • 表结构一致的情况下,在目标库遇到与源库主键的值相同的记录:

      • 表结构不一致的情况下,可能导致只能迁移部分列的数据或迁移失败,请谨慎操作。

      • 如需更改单个迁移对象在目标实例中的名称,请右击已选择对象中的迁移对象,设置方式,请参见库表列名单个映射。

      • 如需批量更改迁移对象在目标实例中的名称,请单击已选择对象方框右上方的批量编辑,设置方式,请参见库表列名批量映射。

      • 如果使用了对象名映射功能,可能会导致依赖这个对象的其他对象迁移失败。

      • 如需设置WHERE条件过滤数据,请在已选择对象中右击待迁移的表,在弹出的对话框中设置过滤条件。设置方法请参见设置过滤条件。

      • 如需按库或表级别选择迁移的SQL操作,请在已选择对象中右击待迁移对象,并在弹出的对话框中选择所需迁移的SQL操作。

      1. 在对象配置页面,配置待迁移的对象。

        配置

        说明

        迁移类型

        说明

        源库触发器迁移方式

        请根据实际情况选择迁移触发器的方式,若您待迁移的对象不涉及触发器,则无需配置。更多信息,请参见配置同步或迁移触发器的方式。

        说明                            

        仅当迁移类型选择了库表结构迁移时才可以配置。

        开启迁移评估

        评估源库和目标库的结构(如索引长度、存储过程、依赖的表等)是否满足要求,您可以根据实际情况选择是或者否。

        说明                            

        目标已存在表的处理模式


        目标库对象名称大小写策略

        您可以配置目标实例中迁移对象的库名、表名和列名的英文大小写策略。默认情况下选择DTS默认策略,您也可以选择与源库、目标库默认策略保持一致。更多信息,请参见目标库对象名称大小写策略。

        源库对象

        在源库对象框中选择待迁移对象,然后单击

        向右小箭头

        将其移动至已选择对象框。

        说明

        迁移对象选择的粒度为库、表、列。若选择的迁移对象为表或列,其他对象(如视图、触发器、存储过程)不会被迁移至目标库。

        已选择对象

        说明                            

      2. 单击下一步高级配置,进行高级参数配置。

        配置

        说明

        选择调度该任务的专属集群

        DTS默认将任务调度到共享集群上,您无需选择。若您希望任务更加稳定,可以购买专属集群来运行DTS迁移任务。

        复制源表Online DDL工具执行过程的临时表到目标库

        若源库使用数据管理DMS(Data Management)或gh-ost执行Online DDL变更,您可以选择是否迁移Online DDL变更产生的临时表数据。

        重要

        是否迁移账号

        请根据实际情况选择是否迁移源库的账号信息。若您选择是,您还需要选择待迁移的账号并确认账号权限。授权方式等信息,请参见迁移数据库账号。

        源库、目标库无法连接后的重试时间

        在迁移任务启动后,若源库或目标库连接失败则DTS会报错,并会立即进行持续的重试连接,默认重试720分钟,您也可以在取值范围(10~1440分钟)内自定义重试时间,建议设置30分钟以上。如果DTS在设置的时间内重新连接上源、目标库,迁移任务将自动恢复。否则,迁移任务将失败。

        说明

        源库、目标库出现其他问题后的重试时间

        在迁移任务启动后,若源库或目标库出现非连接性的其他问题(如DDL或DML执行异常),则DTS会报错并会立即进行持续的重试操作,默认持续重试时间为10分钟,您也可以在取值范围(1~1440分钟)内自定义重试时间,建议设置10分钟以上。如果DTS在设置的重试时间内相关操作执行成功,迁移任务将自动恢复。否则,迁移任务将会失败。

        重要

        源库、目标库出现其他问题后的重试时间的值需要小于源库、目标库无法连接后的重试时间的值。

        是否限制全量迁移速率

        在全量迁移阶段,DTS将占用源库和目标库一定的读写资源,可能会导致数据库的负载上升。您可以根据实际情况,选择是否对全量迁移任务进行限速设置(设置每秒查询源库的速率QPS、每秒全量迁移的行数RPS和每秒全量迁移的数据量(MB)BPS),以缓解目标库的压力。

        说明

        是否限制增量迁移速率

        您也可以根据实际情况,选择是否对增量迁移任务进行限速设置(设置每秒增量迁移的行数RPS和每秒增量迁移的数据量(MB)BPS),以缓解目标库的压力。

        说明

        环境标签

        您可以根据实际情况,选择用于标识实例的环境标签。本示例无需选择。

        是否去除正反向任务的心跳表 SQL

        根据业务需求选择是否在DTS实例运行时,在源库中写入心跳SQL信息。

        配置 ETL 功能

        根据业务需求选择是否配置ETL功能,对数据进行加工处理。

        监控告警

        根据业务需求选择是否设置告警并接收告警通知。

      3. 单击下一步数据校验,进行数据校验任务配置。

        若您需要使用数据校验功能,配置方法请参见配置数据校验。

    7. 保存任务并进行预检查。

      说明

      • 对于不可以忽略的检查项,请单击失败检查项后的查看详情,并根据提示修复后重新进行预检查。

      • 对于可以忽略无需修复的检查项,您可以依次单击点击确认告警详情、确认屏蔽、确定、重新进行预检查,跳过告警检查项重新进行预检查。如果选择屏蔽告警检查项,可能会导致数据不一致等问题,给业务带来风险。

      • 在迁移任务正式启动之前,会先进行预检查。只有预检查通过后,才能成功启动迁移任务。

      • 如果预检查失败,请单击失败检查项后的查看详情,并根据提示修复后重新进行预检查。

      • 如果预检查产生警告:

      • 若您需要查看调用API接口配置该实例时的参数信息,请将鼠标光标移动至下一步保存任务并预检查按钮上,然后单击气泡中的预览OpenAPI参数。

      • 若您无需查看或已完成查看API参数,请单击页面下方的下一步保存任务并预检查。

    8. 预检查通过率显示为100%时,单击下一步购买。

    9. 购买实例。

      • 若迁移实例不包含增量迁移任务,则迁移实例会自动结束。迁移实例自动结束后,运行状态为已完成。

      • 若迁移实例包含增量迁移任务,则迁移实例不会自动结束,增量迁移任务会持续进行。在增量迁移任务正常运行期间,迁移实例的运行状态为运行中。

      1. 在购买页面,选择数据迁移实例的链路规格,详细说明请参见下表。

        类别

        参数

        说明

        信息配置

        资源组配置

        选择实例所属的资源组,默认为default resource group。更多信息,请参见什么是资源管理。

        链路规格

        DTS为您提供了不同性能的迁移规格,迁移链路规格的不同会影响迁移速率,您可以根据业务场景进行选择。更多信息,请参见数据迁移链路规格说明。

      2. 配置完成后,阅读并选中《数据传输(按量付费)服务条款》。

      3. 单击购买并启动,并在弹出的确认对话框,单击确定。

        您可以在迁移任务列表页面,查看迁移实例的具体进度。

        说明

    相关文档

    配置任务常见错误码及排查方法


    热门文章
    更多>